Feature #798

Add a catalog option : scroll to results yes/no

Added by Mérour Xavier about 5 years ago. Updated almost 4 years ago.

Status:ClosedStart date:08/13/2014
Priority:NormalDue date:
Assignee:-% Done:

100%

Category:CATALOG
Target version:4.3.0
Sponsor: Ergonomic impact:
Functional impact:

Description

The V4 introduced in new behaviour when searching in a CATALOG : when the user validates its search, the result page is automatically positionned on an anchor "results" with the text (xx results).

With this behaviour, the user to not see anymore its search bar without scrolling up.
It is somehow confusing because the user looses the search context.

I would suggest to add an option in each catalog (context) : scroll to results yes/no.


Related issues

Related to easySDI - Feature #789: Catalog Search : use GET instead of POST (like in v2) Closed

History

#1 Updated by Blatti Yves almost 5 years ago

  • Related to Feature #789: Catalog Search : use GET instead of POST (like in v2) added

#2 Updated by Blatti Yves almost 5 years ago

  • Status changed from Request For Comments to Request For Votes

#3 Updated by Blatti Yves almost 5 years ago

Technical Committee stated that it's OK to make this new behavior optional.

Attention: linked to #789 because changing to GET will break HTML anchor auto scroll system. Must certainly be re-implemented with JS.

#4 Updated by Mérour Xavier almost 5 years ago

1+ for me

#6 Updated by Magoni Bruno almost 5 years ago

+1

#7 Updated by Magoni Bruno almost 5 years ago

  • Status changed from Request For Votes to Accepted

#8 Updated by Magoni Bruno almost 5 years ago

  • Status changed from Accepted to Affected
  • Assignee set to Blatti Yves
  • Target version set to 158

#9 Updated by Blatti Yves over 4 years ago

  • Status changed from Affected to Resolved
  • % Done changed from 0 to 100

In my sandbox 4.3.0

#10 Updated by Blatti Yves over 4 years ago

  • Status changed from Resolved to Affected

Need a default value !

#11 Updated by Blatti Yves over 4 years ago

  • Assignee changed from Blatti Yves to Villemagne Jérôme

Hi Jérôme,
For this issue, you told me I had to add a default value. But it seems to be there. Do you still encounter a problem with it?
Thanks !

#12 Updated by Villemagne Jérôme over 4 years ago

  • Assignee changed from Villemagne Jérôme to Blatti Yves

Yes, I still encouter it ! It append if you never saved the catalog's config after the solution's upgrade.

#13 Updated by Blatti Yves over 4 years ago

  • Assignee changed from Blatti Yves to Villemagne Jérôme

Your problem is not reproducible on two other instances.
If OK for you, you can close it now Jérôme.

The behavior of JS with no result has been patched in my sandbox.

#14 Updated by Magoni Bruno over 4 years ago

  • Target version changed from 158 to 4.3.0

#15 Updated by Villemagne Jérôme over 4 years ago

  • Status changed from Affected to Resolved

#16 Updated by Villemagne Jérôme over 4 years ago

  • Status changed from Resolved to Closed

#17 Updated by Van Hoecke Hélène almost 4 years ago

  • Assignee deleted (Villemagne Jérôme)

Also available in: Atom PDF