Defect #1191

Fix array usage to be compatible with PHP < 5.4

Added by Van Hoecke Hélène almost 4 years ago. Updated over 3 years ago.

Status:ClosedStart date:11/13/2015
Priority:NormalDue date:
Assignee:-% Done:

100%

Category:SHOP
Target version:4.3.2
Affected version:4.3.2

Description

Since PHP 5.4 it's possible to do that: getSomeArray()[index]

Prior to PHP 5.4, you'll need to use a temporary variable.

Corrections made in :
- /components/com_easysdi_shop/controllers/order.php
- /administrator/components/com_easysdi_shop/layouts/com_eaysdi_shop/order.php

History

#1 Updated by Van Hoecke Hélène almost 4 years ago

  • % Done changed from 0 to 100

#2 Updated by Van Hoecke Hélène almost 4 years ago

  • Status changed from Affected to Resolved

#3 Updated by Van Hoecke Hélène almost 4 years ago

  • Status changed from Resolved to Closed

#4 Updated by Van Hoecke Hélène over 3 years ago

  • Assignee deleted (Van Hoecke Hélène )

Also available in: Atom PDF