Defect #1080

Cannot add a "class association" to a relation having a "resource" childtype.

Added by Blatti Yves about 3 years ago. Updated over 2 years ago.

Status:AffectedStart date:08/12/2015
Priority:HighDue date:
Assignee:-% Done:

0%

Category:CATALOG
Target version:-
Affected version:4.3.2

Description

I cannot save a linked Metadata (a Contact) in MD edit form if the relation has a class association.
On each load the field is empty. And it seems to not be saved in XML.

History

#1 Updated by Blatti Yves about 3 years ago

  • Status changed from New to Affected
  • Assignee set to Battaglia Marc

Hi Marc,
Can we talk about that tomorrow ?

Thanks !

#2 Updated by Blatti Yves about 3 years ago

  • Assignee changed from Battaglia Marc to Blatti Yves
  • Priority changed from Urgent to High

Found the source, in V4 we cannot add a "class association" to a relation having a "resource" childtype.

#3 Updated by Blatti Yves about 3 years ago

  • Subject changed from Unable to save a relation to a resource in MD edition to Cannot add a "class association" to a relation having a "resource" childtype.
  • Description updated (diff)

#4 Updated by Blatti Yves about 3 years ago

  • Assignee deleted (Blatti Yves)

#5 Updated by Blatti Yves over 2 years ago

  • Assignee set to Technical Committee

Since this seems to be 'by design' in easySDI, should we:
- avoid this case
- just document the fact the this should not be done..
?

#6 Updated by Blatti Yves over 2 years ago

  • Assignee deleted (Technical Committee)

This is a defect and can be resolved in the future

Also available in: Atom PDF