Defect #1055

Unable to preview a metadata as editor or responsible if not in access scope

Added by Blatti Yves almost 4 years ago. Updated about 3 years ago.

Status:ClosedStart date:07/03/2015
Priority:NormalDue date:
Assignee:-% Done:

100%

Category:CATALOG
Target version:4.4.1
Affected version:4.0.0

Description

Unable to preview a metadata as editor or responsible if not in access scope.

With delegation, we can manage and edit objects of other organisms.

The problem is specific:
if the user "userA" of organism "orgA" has the rights to edit a resource in organism "orgB": he can edit metadata, diffusion etc...
if the resource has an access scope to "only organism orgB" he will not be able to preview the metadata.

History

#1 Updated by Van Hoecke Hélène about 3 years ago

  • Status changed from New to Affected
  • Assignee set to Van Hoecke Hélène
  • Target version set to 4.4.1

#2 Updated by Van Hoecke Hélène about 3 years ago

  • Status changed from Affected to Resolved
  • % Done changed from 0 to 100

#3 Updated by Van Hoecke Hélène about 3 years ago

  • Status changed from Resolved to Closed
  • Assignee deleted (Van Hoecke Hélène )

Also available in: Atom PDF