PROXY V4 installation problem

Added by bad momo almost 3 years ago

I have a problem installing proxy v4.

when trying to configure virtual service the folowing alterte apear
"Impossible de se connecter à l'instance de Proxy configurée pour invalider son cache"

working on windows with tomcat7 jdk6.

the request :
http://localhost:8080/proxy/ogc?request=GetCapabilities

rerurn the following response :

<ExceptionReport xsi:schemaLocation="http://www.opengis.net/ows/2.0 owsExceptionReport.xsd" version="1.0.0">
<Exception exceptionCode="NoApplicableCode" locator="request">
<ExceptionText>Could not determine proxy request from http request. Service name is invalid.</ExceptionText>
</Exception>
</ExceptionReport>


Replies (3)

RE: PROXY V4 installation problem - Added by Blatti Yves almost 3 years ago

Hi bad momo !

Is it a fresh install ?

Some points you should check:
  • In easySDI's joomla backend: in "Services" open "options":
    (can also be accessed by "System"/ "Global Configuration" then "EasySDI SERVICE" in the left list)
    check that "Service Url" is set to "http://localhost:8080/proxy/" and click save (even if already set in the field)
  • You should check your tomcat logs (catalina): java PROXY may have trouble connecting to your database for example
    in case of connexions to DB problems, see config here

Post your logs here if you need further assistance

RE: PROXY V4 installation problem - Added by bad momo almost 3 years ago

when I try to configure a new map layer the folowong error apear :

"Une erreur est survenue lors de l'interrogation du service : HTTP status 500"

my logs :

localhost_access_log
0:0:0:0:0:0:0:1 - - [14/Nov/2014:15:25:08 +0000] "GET /proxy/virtual-wms?REQUEST=GetCapabilities&SERVICE=WMS&version=1.1.1 HTTP/1.1" 500 433
0:0:0:0:0:0:0:1 - - [14/Nov/2014:15:29:01 +0000] "GET /proxy/virtual-wms?REQUEST=GetCapabilities&SERVICE=WMS&version=1.1.1 HTTP/1.1" 500 433

easysdi-proxy.log
14 nov. 2014 15:29:01,956 ERROR EasySdiConfigFilter:212 - No Policy found for the service. No request can be performed.
14 nov. 2014 15:29:01,956 [http-bio-8080-exec-12] INFO ProxyLogger:70 - ClientResponseDateTime=14/11/2014 15:29:01
14 nov. 2014 15:29:01,956 [http-bio-8080-exec-12] INFO ProxyLogger:72 - ClientResponseLength=433

I had use the backend to configure the virtual service and the access rules.

RE: PROXY V4 installation problem - Added by bad momo almost 3 years ago

I found the problem right now.

in the access rules the date of expiration was set to 1979

I correct that (set to 2025) and now all is working right.

thank you for your help.

(1-3/3)